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HANDS ON, USING 
R COMMANDER
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Using R Commander
• “R” is a sophisticated and free statistical 

programming language.
• R Commander is an add-on, also free, that is 

menu-driven. It doesn’t do everything R does.
• Website for installing R: 

http://www.r-project.org/
• To install R Commander: Open R, then type:
> install.packages("Rcmdr", dependencies=TRUE)

• Wait until it finishes.
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Opening R and R Commander

• Click on the R icon on the desktop to open R.
• At the prompt, type

>library(Rcmdr)
OR go to the R menu Packages → Load package 

scroll down to Rcmdr, and click “OK”
• R Commander should open in a new window.
To close them, in R Commander go to 
File→ Exit→ From Commander and R
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Entering Data by Hand
Data → New data set
• Enter a name for the data set, click “OK”
• A spreadsheet should pop up. Click on “var1” in the 

upper left, type a name (e.g. benzene), click numeric, 
then X out the name box.

• Enter the data into the first column of the spreadsheet.
Example: Enter the 16 Benzene values (Rong)

3.8,  35,  38,  55, 
110, 120, 130, 180,
200, 230, 320, 340, 
480, 810, 980, 1200
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Save data, then try some graphs
• Verify correct entry “View data set”
• Save the data set for later:
Data → Active data set → Save active data set 
• Histogram of benzene (Graphs → Histogram)

– Note that it appears in a separate window
• Stem and leaf plot of benzene
• Boxplot of benzene
• Graphs → Save graph to file → Bitmap → jpeg
• What did you learn about the benzene data from 

the graphs?
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Numerical summaries
Statistics → Summaries → Numerical summaries
Results: Q1    Median   Q2
mean     sd 0%   25%   50%   75% 100%  n
326.9875 362.2683 3.8 96.25  190  375  1200 16

• Note that the quartiles differ slightly from the ones 
computed “by hand” which were 82.5 and 410. 

• The formula R uses for quantiles is i = 1+q(n−1), 
where i is the ordered rank of the q quantile. Here,      
n = 16 and q = .25, so i = 4.75

• If i is not an integer, a weighted average is used. In this 
case, .75 of distance from 55 to 110.
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Benzene data, continued
Interpreting the Results:
mean     sd 0%   25%   50% 75% 100%  n
326.9875 362.2683 3.8 96.25 190 375  1200 16

• From mean and standard deviation alone, we can 
tell that the distribution is not bell-shaped!

• What is it that lets us know that?
• What does the 5 number summary tell us?
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Transforming variables
For reasons more clear later, we would like 

natural log of benzene.
Data → Manage variables in active data set 
→ Compute new variable

Under New variable name put LnBenzene
Under Expression to compute put 

log(Benzene)
View data set to make sure it worked!
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Now do graphs on LnBenzene

• Histogram
• Stem and leaf plot
• Box plot

What do you notice about the shape of 
Benzene compared to LnBenzene?
See next slide for histograms.
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Benzene versus Ln(Benzene)
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Importing Data into R Commander
Data → Import data
You can import data from the following sources:
• Text file in a folder on your computer
• Clipboard
• Internet URL
• SPSS Data sets created by these
• Minitab statistical software packages
• Stata
• Excel
• Access
• dBase

Day 1, Afternoon, Slide 12

Example to Import from Excel
• Data from H&H, years from 1925 to 1989, Annual 

peak discharge, Saddle River, NJ, variable name is 
“Flow” (cubic feet/sec)

• Data → Import data → From Excel, Access...
• Enter a name (e.g. SaddleRiver), click “OK”
• Local files will pop up; find file “EnvStatData”, click 

“Open”, then in the pop up box “Select one table”
click on “SaddleRiver”

• Click View data set to make sure it worked. You 
should see columns labeled “Year” and “Flow”



3

Day 1, Afternoon, Slide 13

“View data set” should 
show something like this.

First column is Year
Second column is Flow

Don’t forget to save the data set:
Data → Active data set 
→ Save active data set
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Summaries for Bivariate Data

• “Bivariate” = two variables measured on each 
“unit.”

• Often there is a natural designation of one as 
“explanatory” variable and one as “response”
variable.

• In plots, x = explanatory, y = response
• Saddle River Example:

Year = x = explanatory
Flow = y = response
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Bivariate Data: Visual Summaries

• Most general is a “scatter plot”
• If x = time (such as year) can do a line graph, 

which connects the dots across time.
Graphs → Line graph

• For scatter plot, can add “least squares line”
and/or “lowess* smoother”
Graphs → Scatterplot

*lowess = locally weighted scatterplot smoother
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Line graph
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Scatter plot with least squares line and smoother
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What to notice in a scatterplot:
• If the average pattern is linear, curved, 

random, etc.
• If the trend is a positive association or a 

negative association
• How spread out the y-values are at each 

value of x (strength of relationship)
• Are there any outliers – unusual 

combination of (x, y)? 
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Saddle River Example

• Somewhat linear
• Positive association
• Quite spread out 
• A few possible 

outliers (1945 in 
particular, shown in 
blue)
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Bivariate data: Numerical summaries
• Algebra Review (Linear relationship)
• Equation for a straight line:

y = b0 + b1x
b0 = y-intercept, the value of y when x = 0
b1= slope, the increase in y when x goes up by 1

• Example: One pint of water weighs 1.04 pounds. (“A 
pint’s a pound the world around.”)

• Suppose a bucket weighs 3 pounds. Fill it with x pints 
of water. Let y = weight of the filled bucket.

• How can we find y, when we know x?
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Water and weight example: A 
deterministic relationship

b0 = y-intercept, the value of y when x = 0
This is the weight of the empty bucket, so b0 = 3
b1 = slope, the increase in y when x goes up by 1 

unit; this is the added weight for adding 1 pint of 
water, i.e. 1.04 pounds.

The equation for the line: 
y = b0 + b1x 

y = 3 + 1.04 x
x = 1 pint → y = 3 + 1.04(1) = 4.04 pounds
x = 2.5 pints → y = 3 + 1.04(2.5) = 5.6 pounds
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Statistical Relationship
• In a statistical relationship there is variation in 

the possible values of y at each value of x. 
• If you know x, you can only find an average or 

approximate value for y.
• Regression equation – to describe the “best”

straight line through the data, and predict y, 
given x in the future.

• Correlation coefficient – to describe the strength 
and direction of the linear relationship
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Saddle River: Numerical Summary
• Regression equation:

Predicted flow = −58299 + 30.65 (Year)
Example: Predict flow value for 1980:
−58299 + 30.65(1980) = −58299 + 60687 = 2388
Actual for 1980: 2470

• Correlation between year and peak 
discharge is .626

• Will do more with these on Day 3.
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R Commander: Regression and Correlation
Statistics → Fit Models → Linear Regression
• Identify the Response variable and Explanatory variable (Ex: 

Flow, Year)
• Partial Results:
Coefficients:

Estimate Std. Error t value Pr(>|t|)    
(Intercept) -58299.189   9417.584  -6.190 5.02e-08 ***
Year            30.647      4.812   6.369 2.48e-08 ***

Statistics → Summaries → Correlation matrix [Highlight variables]
Flow      Year
Flow 1.0000000 0.6258355
Year 0.6258355 1.0000000
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Other Software Options
• See “Resources for Learning about Statistics 

& Data Analysis” by Steve Saiz for options 
specific to State and Regional Water Board

• Excel has some basic statistics options
• Commercial packages are expensive, but very 

powerful (Minitab, SAS, SPSS, etc.)
• Highly recommended website:

www.statpages.org
Has links to hundreds of free statistics websites.
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Hands-On Activity: 
www.statpages.org

Details to be given in class
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Random Variables
• A random variable is a numerical outcome 

of a “random” circumstance.
• Examples:

– Rainfall in Sacramento on a randomly selected 
day in January.

– Nickel concentration in a random grab sample.
– Specific capacity of a randomly selected well in 

limestone in Pennsylvania
– Weight of a randomly selected fish
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Probability Distributions
• Before it’s measured, a random variable 

has a bunch of possible values it could be.
• The range of possible values and their 

associated probabilities make up the 
probability distribution for the random 
variable.

• In many cases the possibilities are anything 
on a continuum: A continuous probability 
distribution. Those will be our focus.
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Examples on next few slides
• Normal distribution: Symmetric, very common in 

nature, often required for statistical procedures.
• Lognormal distribution: A random variable x has a 

lognormal distribution if log of x has a normal 
distribution. Skewed to the right.

• Exponential distribution: Often used to model 
waiting times between events (and has other uses).

R Commander will draw these for you:
Distributions → Continuous Distributions → [Choose] 
→ Plot ...
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Here, log(x) is normal with 
Mean = 0 and s.d. = 0.5.
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Probability Distributions as Models
• Statistician George Box “Essentially no 

models are correct, but some are useful.”
• It is useful to “model” data as fitting a 

particular distribution.
• Common to use normal distribution.
• For skewed to the right, can use log normal. 
• If x is log normal, then do transformation to 

get y = log(x), and y is normal.

Simulated data, 100 lognormal observations

Simulated data, 100 normal observations Simulated data, 1000 normal observations
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Simulated data, 100 exponential observations
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Testing for Fit: A Q-Q Plot

• Q = quantile
• Compare actual data (smallest, next 

smallest, up to largest) with what would be 
expected for a normal distribution.

• Plot these; if “normal distribution” is a good 
model, should see approximately a straight 
line.
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Q-Q Plot, normal data, n = 1000
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Q-Q Plot, log normal data, n = 100
Obvious problems!

Do log transformation, then redo plot –
looks much better
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Shapiro-Wilk Test of Normality
Null hypothesis: Normal model is good

Statistics → Summaries → Shapiro Wilk...
Results for the log normal sample (reject null):
Shapiro-Wilk normality test

data:  LogNormalSamples$obs

W = 0.8702, p-value = 7.152e-08

Results after log transform (don’t reject null):
data:  LogNormalSamples$logobs
W = 0.9896, p-value = 0.6348
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Caution about using a formal test
• A small p-value implies problems with using 

normal model, but a large p-value does not
mean we can accept the normal assumption. 

• Especially a problem for small sample size, 
because test has low “power.”

• Will explain more when we cover hypothesis 
testing.
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Summary
• Graphs and summary statistics are useful:

– For understanding a data set on its own
– For checking whether appropriate model holds, 

such as “normal distribution” or “linear 
relationship,” required for doing further analysis

• If model does not seem appropriate, creating 
a “transformed variable” may work.
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Hands-On Activity: 
To be given in class


